Перейти к содержимому

Фотография
- - - - -

Скрипт работает только в IE, посмотрите в чем дело!


  • Вы не можете создать новую тему
  • Закрытая тема Тема закрыта
Сообщений в теме: 3

#1 ShadowChaser9000

ShadowChaser9000

    Прохожий

    Топикстартер
  • Новичок
  • 0
    2 сообщ.

Отправлено 27 Апрель 2014 в 21:15

Подключил на страницу галлерею для просмотра картинок. http://www.sv-gallery.com/4/wr.html Работает только в IE, Хром и рыжая бестия не хотят запускать скрипт, будь они неладны. Три часа копался, даже скопировал полностью файлы библиотек и исходный код страницы с сайта с демкой галлереи (изменив конечно же пути). На демке работает во всех броузерах, а стоит разместить эту шнягу на моём хостинге - работает только на Эксплорере. Выручайте, в чем беда?


  • 0

Спонсор

#2 BaNru

BaNru

    Пацифизжу

  • суперМодератор
  • 983
    3 516 сообщ.

Отправлено 27 Апрель 2014 в 21:55

Посмотри консоль браузера, там выдает 6 ошибок.
Основная проблема вроде в кодировках.
  • 0

#3 ShadowChaser9000

ShadowChaser9000

    Прохожий

    Топикстартер
  • Новичок
  • 0
    2 сообщ.

Отправлено 27 Апрель 2014 в 22:33

Да, вижу. А что там с кодировками может быть? Я просто не очень продвинутый юзер в плане скриптов, разбираюсь на ходу )


  • 0

#4 BaNru

BaNru

    Пацифизжу

  • суперМодератор
  • 983
    3 516 сообщ.

Отправлено 27 Апрель 2014 в 23:26

Ну могу предположить, что у тебя страница в win1251, а JS работает в UTF-8

Переведи свою страницу в UTF-8, а там дальше будем смотреть если не заработает.

 

Так же попробуй подключить или более раннюю или наоборот более позднюю (последнюю) jQ либу.


  • 0



Похожие темы Свернуть

Статистика

Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 скрытых пользователей