Перейти к содержимому

Фотография
- - - - -

Проблема с отображением на мобильных устройствах


  • Вы не можете создать новую тему
  • Закрытая тема Тема закрыта
Сообщений в теме: 3

#1 licyca

licyca

    Прохожий

    Топикстартер
  • Новичок
  • 0
    2 сообщ.

Отправлено 02 Март 2018 в 16:51

Собственно проблема: при просмотре сайта с мобильных устройств в шапке пропадают элементы. Точнее, при загрузке видно, что "имя" появляется, но затем оно перекрывается фоновым изображением (с паралакс эффектом). При верстке такой проблемы не было, проверяла при помощи плагина для браузера (смотрела как будет выглядеть на устройствах с разными разрешениями) все нормально отображается и никуда не пропадает.

Вопрос, с чем хоть примерно это может быть связано? Сначала думала, что проблема в большом z-index у паралакса, но нет.

Прикрепленные изображения

  • 2018-03-02_15-42-18.png
  • SNfujM4M7fg.jpg

  • 0

Спонсор

#2 BaNru

BaNru

    Пацифизжу

  • суперМодератор
  • 1015
    3 690 сообщ.

Отправлено 02 Март 2018 в 16:59

Ну а в инспекторе смотрела что с ним, когда он исчез?
(я, если честно не пробовал, не было надобности, но файрфокс как-то умеет отладку телефона запускать на компе)
Вариант ещё opacity:0, dispaly:none.

Но всё же я уверен, что всё же с z-index проблема.
Он может не только на паралаксе быть высоким, но и на надписи низким.

Ещё можно в хроме посмотреть, он умеет прикидывать мобильными браузерами тоже.
  • 0

#3 licyca

licyca

    Прохожий

    Топикстартер
  • Новичок
  • 0
    2 сообщ.

Отправлено 02 Март 2018 в 18:30

Ну а в инспекторе смотрела что с ним, когда он исчез?
(я, если честно не пробовал, не было надобности, но файрфокс как-то умеет отладку телефона запускать на компе)
Вариант ещё opacity:0, dispaly:none.

Но всё же я уверен, что всё же с z-index проблема.
Он может не только на паралаксе быть высоким, но и на надписи низким.

Ещё можно в хроме посмотреть, он умеет прикидывать мобильными браузерами тоже.

Происходит что-то странное. Часть стилей подгружалась из файла sass, с чего бы это я так и не поняла, но там поменяла z-index. Теперь в хроме прикидывающемся мобильным браузером все отображается нормально, с мобильного браузера яндекс тоже все нормально, а с мобильного браузера хром элементы по прежнему пропадают :biggrin:


  • 0

#4 BaNru

BaNru

    Пацифизжу

  • суперМодератор
  • 1015
    3 690 сообщ.

Отправлено 02 Март 2018 в 19:38

Может кэш не сбросился и там ещё старые стили?
  • 0



Похожие темы Свернуть

  Название темы Форум Автор Статистика Последнее сообщение
Статистика

Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 скрытых пользователей